1

Closed

Doesn't work on WSS V3

description

Or atleast i can't get it to work. It asks for the following files when I click on the email link:
 
AssetPickers.js
HtmlEditor.js
/styles/portal.css
 
These files didn't exist so I've created empty copies of the files in the locations they required however I now get an error:
 
"Unknown Error"
 
on the popup dialogue. Not very descript but I'm not having a lot of success with this webpart.

file attachments

Closed Nov 19, 2009 at 11:02 AM by Tombo
issue solved

comments

Tombo wrote Nov 11, 2009 at 12:48 AM

Martin,

Open up TEMPLATE\LAYOUTS\ListFeatures\SendEmail.aspx and remove following lines:
  • <SharePoint:ScriptLink ID="ScriptLink3" language="javascript" name="AssetPickers.js" runat="server" />
  • <SharePoint:CssRegistration ID="CssRegistration2" name="portal.css" runat="server" />
I didn't find a reference to the HtmlEditor.js file, so I think this'll do it.
  • Tom

martinjbridge wrote Nov 11, 2009 at 8:14 AM

Thanks Tom,

I've tried this but I still get Unkown Error. I've tried it on another of my sharepoint instances and get the same results. Any other suggestion?

Many Thanks

Tombo wrote Nov 12, 2009 at 1:51 PM

Martin,

Can you post a screenshot? I just tried on a blank installation of WSS, and it worked when I deleted the 2 references I mentioned. Also, try to go to the view properties and page and clicking on the link there.
  • Tom

martinjbridge wrote Nov 13, 2009 at 10:22 AM

Hi Tom,

Thanks for your assistance in resolving this issue, I attach a screen shot for your reference. I will also attach the sendemail.aspx file.

Many Thanks

wrote Nov 13, 2009 at 10:22 AM

martinjbridge wrote Nov 13, 2009 at 10:23 AM

Senemail.aspx

wrote Nov 13, 2009 at 10:23 AM

Tombo wrote Nov 13, 2009 at 4:45 PM

Martin,

Everything seems to be ok. It should work, but it doesn't. Can you enable the custom errors? You can do this by changing following settings in your web.config: http://vspug.com/jessefitz/2008/04/09/sharepoint-web-config-debug-settings/

What error does it give you now?

Have a great weekend!
  • Tom

martinjbridge wrote Nov 14, 2009 at 10:27 AM

Hi Tom,

Thanks for your help on this! I've attached the screenshot of the error, hopefully this helps us pin point why its failling?

Enjoy your weekend

wrote Nov 14, 2009 at 10:27 AM

Tombo wrote Nov 14, 2009 at 12:31 PM

Martin,

I think I found your problem. This lits feature example will give you an option to e-mail the file within a document library (or derived: picture library, form library, ..) If I'm not mistaking, you've activated it on a task list. As it's an example, we didn't add logic to prevent you from adding it to other lists. It does crash now because it tries to render the file of the list item in the window. Unfortunately a task item does not have a file.
You can still activate it on a document library, though.

Thanks for the previous input for WSS. I'll try to release an update for the WSS example.

-Tom

martinjbridge wrote Nov 16, 2009 at 8:08 AM

Thanks Tom, you were right and sorry for taking up your time. The custom errors link is really useful. Thanks

Tombo wrote Nov 16, 2009 at 7:36 PM

No problem Martin! Glad you found the link usefull.

Be sure to post your comments when you develop you own list features.

Thanks for downloading!
  • Tom

wrote Nov 19, 2009 at 11:02 AM

wrote Feb 2, 2013 at 4:22 AM

wrote May 14, 2013 at 7:47 AM